Still Running OS X Yosemite? Beware, iTunes 12.8.1 Breaks Safari

Apple this week launched iTunes 12.8.1 for OS X Yosemite as much as macOS High Sierra. The minor replace resolves a subject that averted iTunes from streaming media to third-party AirPlay audio system, and accommodates different minor enhancements.


However, any person operating OS X Yosemite 10.10.5 in particular must steer clear of updating to iTunes 12.8.1 for now, as customers around the appmarsh Forums, Twitter, Reddit, and Stack Exchange record that the replace come what may breaks Safari 10.1.2, the most recent model of the browser for OS X Yosemite.

After updating to iTunes 12.8.1, some customers have encountered the next error message when opening Safari on OS X Yosemite:

Safari can’t be opened on account of an issue.

Check with the developer to verify Safari works with this model of Mac OS X. You will have to reinstall the applying. Be positive to positive to put in any to be had updates for the applying and Mac OS X.

One person on Stack Exchange believes that the iTunes 12.8.1 replace might replace /System/Library/PrivateFrameworks/MobileDevice.framework to a model incompatible with Safari 10.1.2, however the reason isn’t fully transparent. We’ve flagged the problem with Apple and requested if and when a repair might be to be had.

In the period in-between, workarounds come with the use of an alternate browser corresponding to Firefox or upgrading to a more moderen macOS model — after all, the ones nonetheless the use of OS X Yosemite most likely do not need to or cannot improve. Updating to iTunes 12.9 isn’t conceivable on OS X Yosemite, as that model is most effective suitable with macOS Mojave.

We’ll replace this text when a repair is to be had.

Tags: Safari, iTunes

Discuss this text in our boards